Resolved
The issue has been resolved. Newly created blocks can be restored.
Monitoring
A fix has been deployed. New edits can be restored.
Identified
We have identified the issue and are working on fix
Investigating
Some code versions in the chat history are not able to be restored.